×
Google объяснила, почему не собирается исправлять старые андроиды

Не каждому пользователю понравится, что компания Google не собирается исправлять критические повреждения системы безопасности в старых телефонах. Но теперь понятно, почему.

 

Поисковый гигант заявил, что не делает это потому, что старые версии ниже Android 4.4 уже нежизнеспособны. Патч не поможет там, где придется менять всю структуру, чтобы залатать дыру в безопасности. Само количество необходимых изменений в коде создаст множество проблем, с которыми разработчики не справятся. Тем более что они и так внедряют «тысячи» твиков для программного обеспечения с открытым исходным кодом каждый месяц.

 

Если же пользователи не могут отказаться от обновления до версии хотя бы 4.4, то рекомендуется не использовать WebView. А если без интернет-серфинга никак, то рекомендуется работать с интернет-браузерами, которые не используют данную службу. Например, Firefox (который работает на старом ядре Android 2.3, что действительно не использует WebView).

 

Хакеры не могут злоупотреблять уязвимостью программного обеспечения там, где нет для этого возможностей. Тем не менее компания по-прежнему намекает, что немало людей будут подвергаться риску, пока не обновят свои смартфоны (или не купят новые) до последних версий ОС Android.

 

Стоит отметить, что многие владельцы android-устройств не знают альтернатив android-браузерам или не могут легко получить их по каким-то причинам. Чего, например, стоит установить Chrome, если вы не можете использовать Google Play Store? Много проблем. Кроме того, нет простого способа, благодаря которому можно сказать, использует ли приложение WebView или нет. Так что, похоже, Google просто хочет, чтобы пользователи обновляли свои гаджеты, хотят они того или нет.

 

Автор: Степан Мазур